Mac下安装启动不了 需要的php扩展都装了

systemMessage

由于公司的项目是用了wokerman的 前面一直是再Ubuntu 下跑的workerman 没有问题 ,最近将开发环境换成MacBook 下 就出现一只启动不了得情况,具体如下图 @walkor 谢谢帮忙解答下 谢谢

首先 看了下扩展

[attach]169[/attach]

[attach]170[/attach]

我们自己的项目没有启动成功
然后下载了你们官网的例子试下
没有显示启动成功

[attach]171[/attach]

问下具体问题可能出在哪里

阅读 1972
6个回答

walkor

php 版本是?

systemMessage

版本是 5.5.30

  • 暂无评论
systemMessage

前面开发 我在Ubuntu15 上面试了php5.6 没有什么问题 所以想5.5 应该不会有问题

  • 暂无评论
walkor

mac brew的 5.5.30有bug,无法使用pcntl_signal,换个版本就好了

systemMessage

换个版本就OK了 写了个教程 有兴趣的可以看看 本来是要发在问答上面的
就是发的教程里面有链接 ,问答发不了链接,所以大家可以去这里看

jisec.com/application-development/332.html

  • 暂无评论
walkor

谢谢

  • 暂无评论