请问 Webman 需要安装 安装event扩展(或libevent扩展) 高并发扩展吗

mayibanjia

请问 Webman 需要安装 安装event扩展(或libevent扩展) 高并发扩展吗?
还是说 workerman 全线产品都需要安装

538 3 0
3个回答

blogdaren

默认是不会装的,要想使用高并发,必须自行安装event扩展,同类的扩展还有libevent、ev、swoole等。

  • mayibanjia 2022-04-15

    我知道默认不安装的,就是说,想使用高并发 就要安装就是了。我以为只有workerman需要安装

walkor

event扩展是为了提高并发连接数,如果你只需要webman做http服务,可以不安装event扩展,因为http一般不需要维持很长时间的连接。不会有很高的并发连接数。

比如开启8个进程,每个进程没装event扩展时可以维持1000个连接,总共8000连接对于http协议来说已经够用了

evilk

1.
只要使用workerman相关东西,都无脑安装event扩展

2.
主要是event扩展,不是libevent扩展
因为libevent扩展对PHP7支持不够好,也很久没有更新了
如果是PHP7,建议安装event扩展

  • 暂无评论
🔝