php5.6拓展libevent成功,php7.0拓展失败

dangpengsong

各位大神,我用php5.6拓展libevent成功了,
[attach]1019[/attach]
但是php7.0失败,提示不支持,如果不支持,为什么网上那么多人blog里面写php7拓展libevent的教程,是我安装有问题,还是晚上都是无脑互抄的,实际真的不支持php6.0以上?
[attach]1020[/attach]

阅读 2132
3个回答

yongdao35

http://pecl.php.net/package/libevent
确实不支持php7.0,看更新日志就知道。网上的估计是非官方版本的libevent扩展,最好别用

  • 暂无评论
wintrue

需要编译安装高版本的,github库https://github.com/libevent/libevent

  • dangpengsong 2018-05-02

    网上都是互相抄袭的,高版本也不支持php7,已经改用event了

walkor

libevent扩展不支持 php7,网上的支持php7的libevent扩展并非是官方的,会有问题

  • aidong_wang 2018-07-15

    使用 gateway 项目,php 版本为 php7,部分客户端 TCP 经常断开连接,是否跟只使用了 event 而没有使用 libEvent 有关系?已经确认不是 TCP 客户端的问题

  • walkor 2018-07-16

    event扩展和libevent扩展作用相同,安装一个即可