aapanel 不支持 PHP 8.2,是否可以让 webman 兼容一下 PHP 8.1

= - =

兼容 PHP 8.1 主要改动是需要支持使用低版本的 illuminate 包。

截图

215 1 0
1个回答

six

webman没有依赖或限制illuminate的包啊,装哪个版本的illuminate包是自己决定的,和Webman没什么关系。
一般直接require就可以,composer会自己选择与PHP8.1合适的illuminate包版本

  • = - = 12天前

    这是需要自己手动更新 webman 的依赖后才能使用。我的意思是是否可以默认支持 php8.1, php8.2

  • six 11天前

    截图
    https://github.com/walkor/webman/blob/master/composer.json
    webman的依赖只有 workerman/webman-framework monolog/monolog,没有illuminate包。
    所以没有你说的手动更新webman依赖才能使用的说法。至于你装哪个版本的illuminate包不受webman控制,由你自己决定。
    如果你弄不明白,就通过composer remove illuminate/database illuminate/pagination illuminate/events symfony/var-dumper illuminate/redis删除所有illuminate的包,然后运行 composer require -W illuminate/database illuminate/pagination illuminate/events symfony/var-dumper illuminate/redis 会自动根据你php的版本选择正确的illuminate包版本

  • = - = 11天前

    知道了,可能是安装数据库、缓存的时候,本地环境用的新版本PHP,而服务器用的旧版本PHP。

×
🔝