workerman/getway-worker4.0自定义协议 not exist

ouzai

问题描述

这里详细描述问题

添加一个分布部署的businessworker,然后想着装最新的整个进行了composer update,之后启动不了自定义协议not exist,使用composer降级gateway-worker后可以正常运行了.如果我要使用gateway-worker4.0需要怎么改

报错信息

PHP Fatal error:  Uncaught Exception: class \Protocols\Zlg not exist in /Gateway1/vendor/workerman/workerman/Worker.php:2360
Stack trace:
#0 /Gateway1/vendor/workerman/workerman/Worker.php(2282): Workerman\Worker->parseSocketAddress()
#1 /Gateway1/vendor/workerman/workerman/Worker.php(700): Workerman\Worker->listen()
#2 /Gateway1/vendor/workerman/workerman/Worker.php(555): Workerman\Worker::initWorkers()
#3 /Gateway1/start.php(44): Workerman\Worker::runAll()
#4 {main}
  thrown in /Gateway1/vendor/workerman/workerman/Worker.php on line 2360

截图报错信息里报错文件相关代码

这里粘贴截图

104 1 0
1个回答

walkor

gatewayworker4.0 去掉了再带的自动加载,复用composer的自动加载。
如果不会设置的话使用gatewayworker 3.x 即可

  • 暂无评论
🔝