使用laravel数据库报错喃?怎么处理

manman10
Fatal error: Uncaught Error: Class "PhpOption\Option" not found in C:\Users
\Desktop\zz\code\api\vendor\illuminate\support\Env.php:76
Stack trace:
#0 C:\Users\Desktop\zz\code\api\vendor\illuminate\support\helpers.php(133):
 Illuminate\Support\Env::get()
#1 C:\Users\Desktop\zz\code\api\config\database.php(35): env()
#2 C:\Users\Desktop\zz\code\api\vendor\workerman\webman-framework\src\Confi
g.php(65): include('...')
#3 C:\Users\Desktop\zz\code\api\start.php(28): Webman\Config::load()
#4 {main}
  thrown in C:\Users\Desktop\zz\code\api\vendor\illuminate\support\Env.php
on line 76
1365 3 0
3个回答

mosquito

缺少phpoption/phpoption
可以装这个能使用env也附带了phpoption
composer require vlucas/phpdotenv

  • manman10 2022-08-05

    支持 好了

  • manman10 2022-08-05

    问下 windows 直接运行 php start.php start 怎么支持热更新 。每次更改文件 都要重启才生效

  • manman10 2022-08-05

    windows 可以用 php windows.php 支持热更新

  • mosquito 2022-08-05

    嗯,自己就带了

webman 没有env函数哦,可以使用getenv()函数 composer require vlucas/phpdotenv

  • 暂无评论
不败少龙

composer require vlucas/phpdotenv 应该框架默认就下载 ,昨天我页遇到了这个问题

年代过于久远,无法发表回答
🔝