php5.6 应该用哪个版本的workerman?

hyungook

php5.6

composer require workerman/crontab

运行示例代码提示

Parse error: syntax error, unexpected ':', expecting ';' or '{' in D:\xxxx\vendor\workerman\crontab\src\Parser.php on line 83
Worker process terminated with ERROR: E_PARSE "syntax error, unexpected ':', expecting ';' or '{' in D:\xxx\vendor\workerman\cr
ontab\src\Parser.php on line 83"

因为历史原因不能用php7 版本,

阅读 120
1个回答

walkor

目前workerman最新版本为4.x,最低可支持php5.3。
你这个报错是workerman/crontab的报错,workerman/crontab最低应该是php7,你可以自行修改兼容php5.6,可以的话发个pr我这边合并方便其它PHP低版本开发者