tp5.1安装的think-worker运行php think worker:server 报错

xuhuang

[attach]2048[/attach]
 

阅读 4196
5个回答

xuhuang

[attach]2049[/attach]
 

  • 暂无评论
blogdaren

确保代码中有这行:use Workerman\Worker;  

  • 暂无评论
xuhuang

这个报错,人家说删掉就行,删掉了直接php think worker运行了 换个方法就不行了 

  • 暂无评论
lobtao

使用最新的topthink/worker,就好了,包括mimeType的问题也修复了

  • 暂无评论
xuhuang

 Problem 1
    - topthink/think-worker v3.0.2 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework but these conflict with your requirements or minimum-stability.
    - topthink/think-worker v3.0.1 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework but these conflict with your requirements or minimum-stability.
    - topthink/think-worker v3.0.0 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework but these conflict with your requirements or minimum-stability.
    - Installation request for topthink/think-worker ^3.0 -> satisfiable by topthink/think-worker.
最新版报错
我已经composer require topthink/framework 了

  • lobtao 2019-05-24

    ^3.0只支持tp6.0, ^2.0支持tp5.1

  • xuhuang 2019-05-24

    @997: comp没法直接下载2.0.7的think-worker吧 这个命令php think worker:server好像要求2.0.7版本呢