微信小程序使用HTTPS协议,webscoket 连接 workerman 出现错误。不能连接

512765140

确定了TLS版本是1.2.但还是不能连接WORKERMAN。能使用https获取其他接口。

4176 2 0
2个回答

walkor

发个截图吧,看看具体是什么报错。
有具体报错才好定位问题。

  • 512765140 2017-03-08

    未能完成操作。(OSStatus 错误-9801),这个错误是证书使用的不是TLS1.2版本,但确实是使用1.2版本的,除非在workerman里面用到的证书服务是1.2以下

  • walkor 2017-03-08

    这个不是workerman返回的

walkor

TLS1.2 要求php版本>=5.6,升级下php试下

  • 暂无评论
年代过于久远,无法发表回答
🔝