php7 无法安装

yepo

pecl install channel://pecl.php.net/libevent-0.1.0

pecl/libevent requires PHP (version >= 5.3.0, version <= 6.0.0, excluded versions: 6.0.0), installed version is 7.0.9
No valid packages found
install failed

按照官方的安装步骤,执行命令“pecl install channel://pecl.php.net/libevent-0.1.0”报错,说php版本太高了。

求解:workerMan真的支持PHP7吗?

阅读 2531
1个回答

walkor

目前libevent扩展不支持php7。
可以用event扩展,event扩展支持php7,作用和libevent扩展一样。

另外libevent扩展和event扩展不是必须的,如果在线人数不超过1000人,完全不用装这两个扩展。

  • 暂无评论