关于Gateway-worker升级问题

smile1

问题描述

这里写问题描述

之前的lock 文件
"name": "workerman/gateway-worker",
            "version": "v4.0.0",
            "source": {
                "type": "git",
                "url": "https://github.com/walkor/GatewayWorker.git",
                "reference": "a3e26fa33e41cc7fec4d068414867e971278d572"
            },
            "dist": {
                "type": "zip",
                "url": "https://api.github.com/repos/walkor/GatewayWorker/zipball/a3e26fa33e41cc7fec4d068414867e971278d572",
                "reference": "a3e26fa33e41cc7fec4d068414867e971278d572",
                "shasum": ""
            },
            "require": {
                "workerman/workerman": "^4.0.30"
            },

在我update 以后变成了 
{
            "name": "workerman/gateway-worker",
            "version": "v3.1.1",
            "dist": {
                "type": "zip",
                "url": "https://mirrors.cloud.tencent.com/repository/composer/workerman/gateway-worker/v3.1.1/workerman-gateway-worker-v3.1.1.zip",
                "reference": "3abb497ce2a79c4c4b2addd3263deb08ffeec772",
                "shasum": ""
            },

关键是我没发现官方有4.0的版本呢, 这是什么情况 

这是composer.json

    "require": {
        "workerman/gateway-worker" : ">=3.0.0",
        "vlucas/phpdotenv": "^5.5",
        "monolog/monolog": "^2.8"
    },
308 1 0
1个回答

walkor

4.0是之前发的一个版本,撤销掉了

  • smile1 2023-11-24

    吓死我了, 明白了 大佬

🔝